Scheduled for August 15, 2025 at 6:01 AM – 12:45 PM
Affects
Internet Service
Under maintenance from 6:01 AM to 12:45 PM
The Ridge
Under maintenance from 6:01 AM to 12:45 PM
Completed
August 15, 2025 at 12:45 PMCompleted
August 15, 2025 at 12:45 PMMaintenance has completed successfully.
In progress
August 15, 2025 at 6:01 AMIn progress
August 15, 2025 at 6:01 AMMaintenance is now in progress
Planned
August 15, 2025 at 6:01 AMPlanned
August 15, 2025 at 6:01 AMWe are planning for an overnight scheduled maintenance for crews to perform fiber splicing work on a backbone cable along Mt. Saratoga Blvd. Impacted customers may experience service disruptions during this timeframe.
This maintenance impacts customers in the following address ranges:
Highridge: All units
Ridgehorne: Units West of Mt. Saratoga Blvd
The Ridge: units 878-943 Sagehill Dr.