Scheduled for June 20, 2025 at 6:15 AM – 11:00 AM
Affects
Internet Service
Under maintenance from 6:15 AM to 11:00 AM
The Ridge
Under maintenance from 6:15 AM to 11:00 AM
Completed
June 20, 2025 at 11:00 AMCompleted
June 20, 2025 at 11:00 AMMaintenance has completed successfully
In progress
June 20, 2025 at 6:15 AMIn progress
June 20, 2025 at 6:15 AMMaintenance is now in progress
Planned
June 20, 2025 at 6:15 AMPlanned
June 20, 2025 at 6:15 AMWe are planning for an overnight scheduled maintenance for crews to perform fiber splicing work on a backbone cable along Mt. Saratoga Blvd. Impacted customers may experience service disruptions during this timeframe.
This maintenance impacts customers in the following address ranges: 878-943 Sagehill Dr, 1504-1578 Skyline Dr (even house numbers only), 896-974 Olson Dr, 1394-1486 Russo Dr, and 1434-1439 Boseman Way.