Avative - Customer Billing Portal Cloud Service Outage – Incident details

All systems operational

Customer Billing Portal Cloud Service Outage

Resolved
Degraded performance
Started about 2 months agoLasted about 11 hours

Affected

Billing Portal

Degraded performance from 10:55 PM to 9:40 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    Our backend billing software provider is currently experiencing an issue related to a widespread Microsoft Azure outage. The Avative Customer Billing Portal will be unable to load account details until these cloud services are restored.