Avative - Billing Portal Unavailable – Incident details

All systems operational

Billing Portal Unavailable

Resolved
Under maintenance
Started 6 days agoLasted about 4 hours

Affected

Billing Portal

Under maintenance from 3:02 PM to 7:24 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    Our backend billing software provider is currently down. Access to the billing portal will return shortly.