Fiber Cable Replacement - Daybreak Condos/Harvest Point Commercial
Completed
Scheduled for May 16, 2025 at 3:00 PM – 7:00 PM
Affects
Internet Service
Under maintenance from 3:00 PM to 7:00 PM
ABC North
Under maintenance from 3:00 PM to 7:00 PM
Updates
Completed
May 16, 2025 at 7:00 PM
Completed
May 16, 2025 at 7:00 PM
Maintenance has completed successfully
In progress
May 16, 2025 at 3:00 PM
In progress
May 16, 2025 at 3:00 PM
Maintenance is now in progress
Planned
May 16, 2025 at 3:00 PM
Planned
May 16, 2025 at 3:00 PM
We are planning a maintenance window for a fiber cable replacement beginning at 9:00am MST. We anticipate a brief period of downtime within this maintenance window as we work to install/test the new cable. The work will conclude by 1:00pm MST. This only impacts customers in the following neighborhoods: Daybreak Condos and Harvest Point Commercial.